Studio One 3 Configuration for Amplitube Pedal Board Control

As I post about Studio one here or there, and use Amplitube quite heavily, I have gotten quite a few requests in regards to setting up Studio One with an external device to control the Plug-In. My most recent request was in a blog comment so I’ve decided to just create a post covering the bare minimum basics. The following example uses the latest version of Studio One (3), Amplitube 3, a Roland GR-55 guitar synth controller, and a MOTO Express interface. That said, the fundamentals will apply to any hardware as long as you have input/output capability within Studio One. So let’s dive in.

Step 1: Configure your Device

s1-at3-go-to-setup

 

Launch into Studio One then navigate to the configure external devices. Here we will setup the GR-55/Controller to route from the MIDI interface into the Studio One environment.

s1-at3-external-devices

The Options window will launch with External Devices selected. Click the Add button.

s1-at3-new-keyboard

This is what throws most people. Studio One is a little different (at least in my experience) with past DAWs in that they make a clear distinction between devices in the form of Keyboards, Instruments, and Control Surfaces. While I’ve never really delved into the actual functional characteristics of these classifications, to me they are all still just MIDI based devices. In a nutshell, Studio One assumes Keyboards are for input … so a MIDI controller can fall under this category. Instruments are outboard gear, and control surfaces appear to be more for transport/mixer control. If your current device is in the list of manufacturer folders, select it. Otherwise select to Add a new keyboard then Enter the Man/Model and device name. In the lower panel select the MIDI input port where the device is connected then click OK.

s1-at3-add-device-params

This is the view of a device that was previously added. Note how the devices are grouped by manufacturer. Now close out of the Options/External Devices dialog.

Step 2: Setting Up Your Tracks

Things become very simple now.

s1-at3-add-audio-track

 

Create an audio track for the guitar input then add AmpliTube to the insert route for the audio channel.

s1-at3-add-controller-track

Now add an instrument track (this is the key part) and select the GR-55 input device we created. Next for Output you will want to select “Existing Instrument” followed by selecting the AmpliTube VST instance followed by the operating/intended channel for control. Click OK.

s1-at3-two-tracks-midi-armed

Now you can see both your audio channel, and the controller channel active in the interface. Within the controller channel you will note that the link to Amplitube3 and channel are visible.

Step 3: Map MIDI controllers to Amplitube

Launch into the Amplitube3 instance then drop a pedal on the floor. In this example I’ll use the staple Wah 46.

s1-at3-learn-wah

Right mouse click the element within the interface (switch, knob, pedal) and select Assign Midi -> Learn […]

s1-at3-waiting-input

The plug in is now awaiting input. Simply touch your external controller pedal and the dialog will close followed by the pedal responding to your external controller. Close the running Amplitube instance.

Step 4: Have Fun

That’s it! The only thing to point out is the record/monitor options in Studio One. You have two options here. You can either …

s1-at3-two-tracks-midi-armed

Leave both tracks Armed for record where the MIDI data will be laid down alongside the audio track (along with options for later editing). Or…

s1-at3-midi-activity

You can simply leave the controller in monitor mode while recording audio. This will allow you to go back and “draw” the control curves manually. Sometimes I have a very specific series of things I wish to accomplish that just aren’t practical with only two feet … this is an example of when I will just lay down the track then add the control data after the fact.

That’s it. Go forth and create.

2 thoughts on “Studio One 3 Configuration for Amplitube Pedal Board Control

  1. AHHHHHHH…..Thankyou my man!!!
    I was trying to put Amplitube on the Instrument track and nothing on the Audio track.
    It’s all working great now – thankyou.

    Like

    1. I also wasn’t registering the foot controller as a keyboard. I was doing it as a controller and it wasn’t showing up.

      Like

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s